Eclipse + Pentaho

No replies
Offline
Joined: 23/02/2017
Puntos: 3

Buenas tardes,

Quisiera preguntar, por si hay alguien que tenga la clave, acerca de un problema que me he encontrado lanzando un job de Pentaho desde Eclipse.

El job, uno pequeñito de prueba, genera un txt, un xls y un xml con los datos obtenidos en una tabla. En pentaho, todo OK, pero al lanzarlo desde Eclipse... me genera el archivo txt y xls correctamente, pero el xml no lo crea, no nada, pero en la consola aparece como todo OK. No hay errores.

Sospecho que el problema tiene por un asunto de librerías, pero no soy capaz de dar con la tecla

¿Alguien sería capaz de darme alguna pista por la que seguir? 

El código de la llamada, desde u proyecto java normal, lo pongo abajo.

 

Saludos, y muchísimas gracias anticipadas.

 

Marian

 

  public static void main(String[] args) {
    // TODO Auto-generated method stub
    try {

      KettleEnvironment.init();

      String ruta = "D:\\_PIctus\\Ingesta_Marian\\Proceso_Ingesta.kjb";

      JobMeta jobMeta = new JobMeta(ruta, null);

      jobMeta.setLogLevel(LogLevel.ROWLEVEL);

      Job trabajo = new Job(null, jobMeta, null);

      trabajo.setLogLevel(LogLevel.ROWLEVEL);

      trabajo.run();
      trabajo.waitUntilFinished();
      if (trabajo.getErrors() > 0) {
        System.out.println("Error en la ejecución");
      }
      trabajo.stopAll();
      KettleEnvironment.shutdown();
      System.out.println("FIN");
    } catch (Exception e) {
      // TODO Auto-generated catch block
      e.printStackTrace();
    }
  }

 

 

 



 

  BI   |    CRM     |    CMS    |    Tendencias en software empresarial    |    Cloud computing  |    Software libre    |   Internet    |    Movilidad y apps